Hướng Dẫn Cách viết 1 module đơn giản trong OpenERP cho người mới học.

Thảo luận trong 'Công Cụ Phát Triển' bắt đầu bởi xuantongmuoi, 23/6/13.

  1. admin Administrator

    Chào bạn,
    Lỗi này là do bạn chưa kết nối được tới OpenERP server; bạn kiểm tra lại xem OpenERP server đã chạy hay chưa? Nếu rồi thì kiểm tra xem OpenERP server đang chạy ở cổng nào (thông thường là 8070 đối với GTK client); nếu chưa thì start OpenERP server.
    Hi, chào mừng bạn tham gia diễn đàn OpenERP Việt Nam :)
    Thân chào bạn!
  2. anlh Member

    Hi bạn,

    Bạn xem lại port kết nối với server đi. Port 5432 là của postgress.

    Chúc vui
  3. dokhacthi New Member

    Chào ACE terp.vn,
    Mình làm support về kế toán cho OpenERP. Công việc này phải thường xuyên import dữ liệu cho khách hàng và mình gặp 1 vấn đề rất khó chịu sau và mong các ACE hiểu về code ERP có hướng giải quyết:
    1. Dữ liệu import vào phải tương thích hoàn toàn tuyệt đối với phần mềm kể cả chữ hoa, chữ thường
    2. Vấn đề này sẽ rất rắc rối và mất thời gian cho việc import khi dữ liệu import vào lớn (vài ngàn dòng), ví dụ import Tồn kho đầu kỳ, dữ liệu kế toán đầu kỳ... vì phân biệt chữ hoa, chữ thường nên khi 1 dòng trong cả ngàn dòng có sự khác biệt là văng ra và phải import lại từ đầu. (Khác biệt chữ hoa, chữ thường là không tránh khỏi khi chuyển giao dữ liệu pm mới, dữ liệu pm cũ do người dùng cung cấp)
    3. Mình không rành về code nên không biết giữa chữ hoa, chữ thường có sữ khác biệt lớn như thế nào về code? Và ACE có cách nào xử lý vấn đề này ko để tiết kiệm thời gian và hiệu quả triển khai?
    Xin cảm ơn ACE của diễn đàn và chúc diễn đàn ngày càng sôi động
  4. bruce.nguyen Active Member

    Dear dokhacthi,

    - Bạn có thể contact mình qua profile bên dưới, mình có thể help được bạn điều này
    - Được biết bạn là chuyên support về Accounting, hy vọng hợp tác và học hỏi đc về kế toán từ bạn và mình sẻ support về kỷ thuật free nếu bạn share với mình :)

    Have fun today :)
    Leo Tran thích bài này.
  5. Leo Tran Active Member


    Thế bạn ấy không share thì có được support free ko ? :D (hỏi vui tý)
    fanha99 thích bài này.
  6. bruce.nguyen Active Member

    Dear Leo.Tran,

    - Vô tư nhé :)

    Rgds
  7. Phan Văn Rở New Member

    Mình viết module..run nó thì báo không có lỗi gì hết..nhưng khi vào OPenERP tìm thì không thấy module đâu..Xin chỉ giúp

    Các file đính kèm:

  8. Phan Văn Rở New Member

    Bị bênh gì zậy? Mình viết module nhưng khi run thì tim ko thấy nữa..."installable" được mình gán là True.hjx..code ngay hàng thẳng lối luôn.Giúp với
  9. admin Administrator

    Hi bạn,
    Bạn vào Setting > Users > Users, thêm quyền Technical Features cho user đang dùng; sau đó reload lại browser; vào menu Setting > Module > Update Module List; nhấn nút Update.
    Sau đó, vào menu Installed Module, bỏ filter Installed; tìm tên module bạn là thấy (nếu module bạn viết không bị lỗi.)
    Thân chào!
  10. chaungan_0603 New Member

    Mọi người cho em hỏi với, em đã cài hết tất cả rồi, cũng viết thử 1 module mới, nhưng sau khi chạy file openerp-server.py thì lại hiện ra console như thế này. Vào localhost:8069 thì không thấy module mới được cập nhật lên. Như vậy là em làm sai chỗ nào ạ?

    Các file đính kèm:

  11. 0zero4four New Member

    mình cũng mới cài đặt theo tut của forum mình cũng gặp trường hợp giống bạn sau đó mình restart máy tính lại thì lúc ở màn hình đăng nhập của máy tính mình có them user:eek:penerp....hay gì gì đó bên cạnh user admin,sau đó mình đăng nhập vào user của mình,mình xóa user của thèn openerp đi,thì lúc đó openerp7 của mình chạy được,mình xài win 8,bạn coi thử
  12. chaungan_0603 New Member

    Mình dùng bản openerp 6.1. Khi vào cập nhật module như trong hình đính kèm thì vẫn hiện số module thêm vào vẫn là 0 chứ không phải là 1. Trong mục user của mình không có hiện thêm user của openerp như của bạn, chỉ trong thư mục User trong ổ C thì có thư mục openpgsvc.

    Các file đính kèm:

  13. Đinh Công Minh New Member

    Chào mọi người, mình là thành viên mới đang nghiên cứu về openErp, hiện mình đang cài đặt bản 8.0
    Sau khi cấu hình eclipse để làm thử module theo hướng dẫn tại địa chỉ:
    http://mokepigu.wordpress.com/2010/08/26/tạo-module-mới-cho-openerp/
    mình đã làm và cài đặt thành công, nhưng khi vào module này thì không thể thực hiện các thao tác được:
    trên menu "Create a new book" được có bác nào biết nguyên nhân như thế nào giúp mình với nhé. Thank All :), mình tài file ảnh đính kèm nhưng không được, bác nào đã làm rồi thì chỉ cho mình nhe.
  14. anlh Member

    Dear Minh,

    Do bạn không chụp hình menu bạn tạo ra nên mình không chắc. Mình đoán là do menu của bạn chi có 2 cấp. Từ version 7 trở đi, menu được gắn action thường là cấp thứ 3.
    VD:
    Book Manager.
    List Book.
    Create a new book (action được gắn ở đây).
    chúc vui.
    Đinh Công Minh thích bài này.
  15. quyet New Member

    Bạn Bruce Nguyen bạn có thể cho mình xin Suorce để mình tham khảo được không ạ. Cảm ơn nhiều :)

Chia sẻ trang này