Cài đặt, cấu hình Eclipse để lập trình OpenERP 7.0 (Windows)

Thảo luận trong 'Công Cụ Phát Triển' bắt đầu bởi admin, 12/1/13.

  1. qshady New Member

    anh cho em hỏi với,
    • Cài đặt Eclipse
    • Cài đặt Python
    • Cài đặt Pydev để làm gì? Em mới bắt đầu, chưa hiểu gì cả, mong anh giúp em ạ
  2. qshady New Member

    Anh chị cho em hỏi với, em mắc lỗi nay khi cài đặt Eclipse, rất mong anh chị giup em ạ!
    [IMG]
    --- merged: Aug 6, 2013 9:09 AM ---
    Anh chị cho em hỏi với, em mắc lỗi nay khi cài đặt Eclipse, rất mong anh chị giup em ạ!
    [IMG]
    --- merged: Aug 6, 2013 9:10 AM ---
    1222.png
    --- merged: Aug 6, 2013 9:10 AM ---
    1222.png
  3. bruce.nguyen Active Member

    install jdk và jre vào
    qshady thích bài này.
  4. anlh Member

  5. tqtrung13 New Member

    Xin chào các bạn: hiện mình đang cài openERP nhưng tới bước RUN thì không chạy được và bị báo lỗi như sau:
    Traceback (most recent call last):
    File "G:\openERP\openerp-7.0-20130812-231022\openerp\osv\fields.py", line 46, in <module>
    import openerp
    ImportError: No module named openerp
    Ai biết đây là lỗi gì và có thể chỉ mình cách khắc phục được không? mình cám ơn.
  6. bruce.nguyen Active Member

    :confused: Nó bị lổi vì nó ko import đươck package openerp :p:p
  7. qshady New Member

    Thanks anh @bruce.nguyen và @anlh em đã làm được
    --- merged: 25/8/13 lúc 6:39 PM ---
    Anh ơi em chưa tạo được pydev project mới, em đã làm theo hướng dẫn là giải nén pydev vào thư mục Eclipse. Nhưng khi bật eclipse lên thì không có . Anh chị giúp em với

    2.png
  8. mrkhuongcc Member

    Chào bạn, bạn phải giải nén và coppy những phần sau vào đúng thu mục của nó:
    features => vào features của eclipse,
    plugins => vào plugins của eclipse.
  9. lamabao New Member

    Đơn giản hơn bạn mở eclipse lên sau đó vào help->install new sofware ->sau đó tìm filed work with đánh dòng này vô PyDev Update Site - http://pydev.org/updates rổi nó hiện ra sau đó install
  10. anlh Member

    Hi em,

    em giai nen pydev vao thu muc ...\eclipse\dropins moi duoc.

    Chuc vui.
    qshady and bruce.nguyen like this.
  11. huy_nguyen_41 Member

    Chào mọi người !
    mình muốn hỏi là về chức năng thì bản 7.0 so với bản 6.1 có hơn nhiều gì chức năng k ?
    tại vì mình mới nghiên cứ 7.0 xong mấy cái cơ bản tạo object, view , action, report thấy hơn mỗi giao diện (thậm chí search thấy dùng k quen, khi mà đặt nhiều field để search còn thấy khó tìm hơn 6.1) ngoài ra chưa thấy khác gì trong code, mong mọi người chỉ giúp những cái hơn của 7.0 để tiếp tục có hướng nghiên cứu !
    thank all ! :)
  12. bruce.nguyen Active Member

    - Thực tế là search của 7.0 hay hơn rất nhiều so với 6.1, cơ bản là chưa control được nó nên thấy khó xài.
    huy_nguyen_41 thích bài này.
  13. nhan27165 New Member

    chào mấy a, cho e hỏi, e đã làm theo các bước như hướng dẫn trên, nhưng khi chạy thì báo lỗi, mấy anh chỉ dùm, thanks nhiều

    Untitled.jpg
  14. huy_nguyen_41 Member

    thiếu các thư viện osv, orm,... chắc do quá trình bạn cài thư viện không thành công-> xem lại các bước cài thư viện !
    nhan27165 thích bài này.
  15. Quanvm Member

    Hi bạn,
    Bạn có thể down gói source openerp-7.0-20130822-231054.tar.gz này, nó không có lỗi về "import win32service as ws"
    Mình sẻ edit lại nội dung hướng dẫn sớm nhất cho các bạn

    Thân!
    nhan27165 thích bài này.
  16. bruce.nguyen Active Member

    Dear nhan: E xài window 64 bit à :)
  17. nhan27165 New Member

    e xài win 32 bit a
  18. anlh Member

    Hi nhân,

    E tìm pywin32-214.win32-py2.7.exe cài vô là được.

    Chúc vui
    nhan27165 and bruce.nguyen like this.
  19. phamduong New Member

    Chào tất cả thành viên của 4rum. Mình mới bắt đầu làm quen với OpenERP và cũng dang thử với lập trình trên OpenERP.
    Tuy nhiên khi cài đặt và tạo project mới thì xuất hiện lỗi, đặt tên project thế nào cũng không được (mình đã làm theo các bước cài đặt như admin forum đã hướng dẫn).Nhờ mọi người xem hỗ trợ mình với.
    Hình ảnh: mình đã project.jpg đính kèm
  20. bruce.nguyen Active Member

    Dear phamduong:

    1. Ban choice option 1: Add project directory to the PyThonPATH

    2. Bạn xài eclipse thì hơi nặng khi development

Chia sẻ trang này